I'm speaking at OpenWorld 2017

Wednesday, 19 May 2010

8.50 App Engines stuck in queued status

Just applied PeopleTools 8.50.08 patch and found a problem with App Engines getting stuck at queued. At first I thought it was the patch but it appears to be a bug with using %CURRDATE% in the PSPRCS.CFG file Output Directory Optional Extension= directive.

The error you get in the SCHDLR_mmdd.LOG file is

PSPAL::UnhandledExceptionFilter::UnrecoverableExceptionFilter

I've retested this on the recently released patch 09 and it's not fixed so have raised an SR with Oracle

More on our 8.50 experiences soon.

4 comments:

SergeB said...

Hello Graham
I'm Serge from France
I'm peopleSoft administrator and I'm upgrading Oracle+PreopleSoft from Oracle 9i + PeopleTols 8.45.18 to Oracle 11.2 + PeopleTools 8.50.08
Depending the windows box I use, I have problem when I configure a windows batch server.

when I configure a Windows Batch server (PSNT) on my own work stattion, this opne start in success and I can run Crystal reports

When i configure the same PSNT (accessing to the sane DMO db), from the server previously in tools 8.45.18 and upgraded to tools 8.50.08, this PSNT do not start
I receive the following message:
exec PSMSTPRC -o ".\LOGS\stdout" -e ".\LOGS\stderr" -A -- -CD PPF88DMO -PS PSNT -A start -S PSMSTPRC :
CMDTUX_CAT:1685: ERROR: Application initialization failure

tmboot: CMDTUX_CAT:827: ERROR: Fatal error encountered; initiating user error handler

the "MSTRSCHDLR_0628.LOG" log file contains the following:
PSMSTPRC.248 (0) [06/28/10 11:04:27](0) PeopleTools Release 8.50.08 (WinX86) starting. Tuxedo server is BASE(1)/102
PSMSTPRC.248 (0) [06/28/10 11:04:27](0) Cache Directory being used: D:\psoft\PP\ppfsd01\appserv\prcs\PPF88DMO\CACHE\CACHE\PSMSTPRC_102\
PSMSTPRC.248 (0) [06/28/10 11:04:28](3) File: SQL Access ManagerSQL error. Stmt #: 2 Error Position: 0 Return: 8097 - Oracle initialization error
PSMSTPRC.248 (0) [06/28/10 11:04:28](0) Server failed to start

the "TUXEDO" log file contains the following:
110427.A01SVFSCMRDD1!BBL.580.4028.0: 06-28-2010: Tuxedo Version 10.3.0.0 with VS2005, 32-bit, Patch Level (none)
110427.A01SVFSCMRDD1!BBL.580.4028.0: LIBTUX_CAT:262: INFO: Standard main starting
110427.A01SVFSCMRDD1!PSMSTPRC.248.2824.-2: 06-28-2010: Tuxedo Version 10.3.0.0 with VS2005, 32-bit
110427.A01SVFSCMRDD1!PSMSTPRC.248.2824.-2: LIBTUX_CAT:262: INFO: Standard main starting
110428.A01SVFSCMRDD1!PSMSTPRC.248.2824.-2: LIBTUX_CAT:250: ERROR: tpsvrinit() failed
110428.A01SVFSCMRDD1!tmboot.2216.2184.-2: 06-28-2010: Tuxedo Version 10.3.0.0 with VS2005, 32-bit
110428.A01SVFSCMRDD1!tmboot.2216.2184.-2: tmboot: CMDTUX_CAT:827: ERROR: Fatal error encountered; initiating user error handler
110431.A01SVFSCMRDD1!BBL.580.4028.0: CMDTUX_CAT:26: INFO: The BBL is exiting system

the "ULOG" file contains the following:
105803.A01SVFSCMRDD1!tmshutdown.1460.3832.-2: 06-28-2010: Tuxedo Version 10.3.0.0 with VS2005, 32-bit
105803.A01SVFSCMRDD1!tmshutdown.1460.3832.-2: LIBTUX_CAT:334: ERROR: No BBL
105803.A01SVFSCMRDD1!tmshutdown.1460.3832.-2: FATAL: internal error: CMDTUX_CAT:764: ERROR: can't attach to BB

have you information or idea about this isses

great tahnks for ypu help


serge.blondy@saint-gobain.com

Graham said...

Hi Serge

I've not seen this specific problem before.

Sorry to state the obvious but you need to focus on the differences between your local workstation where it works and the windows server where it does not.

One problem I hit with windows servers is that you MUST use the 32bit version of ODBCAD32.EXE (C:\WINDOWS\SysWOW64\odbcad32.exe) when creating your app and batch server. You need to delete the DSN created with 64bit version and re-create using 32bit version.

Good luck.
Graham

STORMIN30 said...

Hello Graham,

Did you ever find a resolve to this issue? We are experiencing it as well. E-RD: "Tuxedo server is " error on Windows 2008 64-bit and report distribution remains in "Posting" [ID 1110704.1] fits our symptoms but is not applicable to our environment.

Thanks.

Norm

Graham said...

The issue of using %CURRDATE% in the report repository path in the prcs.cfg file is resolved in patch 13 of 8.50 I've been told by Oracle today.