Friday, 10 June 2011

Portal Index Fail

From PeopleTools 8.50 the PS_HOME and PS_CFG_HOME can be in different directories. Not going to discuss why you'd do this here but I'm finding many customers are choosing to separate their configuration from their PS programs.

Well we discovered a problem with running the Portal Index process PORTAL_INDEX with the separated design. The process runs to success but does not create any indexes.

One of our senior developers here at Oxfam, Scott Horman, found the solution and with his permission I'm posting it here.

When you run the process it creates the indexes in the PS_CFG_HOME\SEARCH\EMPLOYEE folder on the batch server. If you don't use PS_CFG_HOME to split config and programs then the indexes get created in PS_HOME\SEARCH\EMPLOYEE. However, the PORTAL_INDEX process looks for the STYLES folder in PS_HOME\DATA\EMPLOYEE and needs this in order to properly create the indexes. If this folder does not exist then the process runs to success without any warnings but fails to create the indexes.

We had made the mistake of assuming that because of this new configuration no longer writes indexes to PS_HOME\DATA we were safe to delete all the contents of the DATA directory on our batch server. Doing this will cause the create index to fail. You must leave the STYLES folder and all it's contents in PS_HOME\DATA



1 comment:

Neha said...

Very nice info. If you want to enhance your knowledge related to PeopleSoft Testing then follow the link to register for Hexaware Technologies Webinar: PeopleSoft Testing Made Easy - How To Reduce Your Testing Cost & Not Your Hairline? https://www2.gotomeeting.com/register/747102810